Download app

An app must be downloaded and installed before you can enter web conference rooms. This is only required once or when updating the plugin to a newer version.
CURRENT VERSION:2.52

Plugin for OSX 10.7 (Lion) and newer:

App Download

Or go to the Apple Store and download and install the tcConference app. This is the preferred approach as the app will have been thoroughly scrutinized by Apple. However there will be a delay of a couple of weeks from the time updates are submitted to Apple before they are available from the Apple Store.

Click for System Requirements

Click for Tutorial

App for OSX 10.6 (Snow Leopard) only:

App Download for OSX 6 ONLY

This app does have known issues and may disconnect more frequently than normal. No further updates are planned.

Close Window